Inbound Call Failures

Incident Report for Commio Status

Resolved

Our team has continued to observe normal inbound call completion. At this time inbound calling functionality has been fully restored. If you experience any issues please open a ticket by emailing support@commio.com.
Posted May 01, 2026 - 01:27 EDT

Monitoring

We have identified the issue causing some inbound calls to fail, and a fix has been implemented. At this time we are monitoring for stability.
Posted Apr 30, 2026 - 23:48 EDT

Investigating

We are currently experiencing a service issue that is affecting inbound calls. We're hard at work on the issue. More details will be provided as we research the issue and understand a resolution timeline. Stay tuned. Send a ticket to support@commio.com and monitor service status via: http://status.commio.com
Posted Apr 30, 2026 - 20:58 EDT
This incident affected: Inbound Voice.